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INSTALLING ACE

Section 1:  Installing ACE
The Garmin Aviation Checklist Editor (ACE) software 

application is designed to help build and customize aircraft 
checklists for the G3X, G300, GDU 37X, GPSMAP 696, 
and Integrated Flight Deck systems.  This Garmin software 
application resides on a CD-ROM and can be installed 
on any PC that uses a Microsoft Windows 98, 2000, XP, 
or Vista operating system (OS).  G900X customers may 
also download the software from my.Garmin.com, G3X 
customers may download the software from Garmin.com.

	 NOTE: Reference to ‘ACE compatible products’ 
throughout this document apply equally to 
the G3X, G300, GDU 37X, GPSMAP 696, and 
Integrated Flight Deck systems.

	 NOTE: Additional Microsoft downloads may be 
needed for Vista compatibility.  If needed, Vista 
will provide instructions on how to download 
these plug-ins.

Installing the ACE software application:

1. Insert the ACE CD-ROM into the CD-ROM drive 
of the PC on which this software application 
is to be installed.  If auto-run is enabled, the 
installer file should automatically start running.  
If this file does not start, click the ‘Start’ menu 
button, select ‘Run...’, then type in the drive 
letter of the CD-ROM drive and click ‘OK’.

2. Once the installer file is running, the InstallShield 
Wizard window is displayed for a few seconds 
while the installer verifies the version of the 
operating system, then an Aviation Checklist 
Editor (ACE) – InstallShield Wizard window is 
displayed, prompting the user to continue the 
installation process.  Click ‘Next’.

3. A window containing the End User License 
Agreement (EULA) is displayed.  After carefully 
reading the terms of this agreement, select 
the  option ‘I accept the terms in the license 
agreement’ if you agree with the terms, then 
click ‘Next’.

4. A window containing a default destination 
folder for the ACE software application is 
displayed together with an option to select 
a different destination folder.  Once the 
destination folder has been set, click ‘Next’.

5. Before the software installation starts, a 
window is displayed, prompting the user 
to either review the installation settings by 
clicking ‘Back’ or proceed with the installation 
by clicking ‘Install’.  Click ‘Install’ to install the 
ACE software application.

6. After the software application has been 
successfully installed, a window is displayed, 
prompting the user to exit the InstallShield 
Wizard.  Click ‘Finish’ to exit the installer file.

	 NOTE: Figure 1-1 shows the various windows 
that are displayed during the ACE software 
application installation process.

Launching the ACE software application:

1a. If the option to ‘Launch the program’ appeared  
checked in the last InstallShield Wizard installer 
window, the ACE software application should 
be automatically launched right after the user 
exits the installer file (this option is checked by 
default).

1b. If the ‘Launch the program’ option has been 
unchecked, go to the selected destination 
folder for this software application and double-
click the file named “ACE.exe”.
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Figure 1-1  Installing ACE

Step 2
Once the installer file starts running (Step 1),  

InstallShield Wizard automatically checks the OS Version

Step 4

Step 6

Step 3

Step 5
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Section 2:  Using ACE

2.1	 Interface Description

The ACE user interface (Figure 2-1) is an aviation 
checklist building platform composed of a menu bar and 
two (2) user-sizable frames.  ACE can also be configured 
to display a toolbar as well as a status bar.

Figure 2-1  ACE Interface

Menu Bar

Status Bar

Working Frame Preview Frame

Toolbar



Garmin ACE User’s Guide 190-00348-00  Rev. C4

USING ACE

Menu Bar

The menu bar features the following menus (menu 
options are listed in parentheses):

• File (New, Open, Save, Save As, Exit)
• Edit (Undo, Redo, Cut, Copy, Paste, Delete, Add 

New Group, Add New Checklist, Add New Entry, 
Group Properties, Checklist Properties, Entry 
Properties, File Properties)

• View (Toolbar, Status Bar)
• Help (ACE Help, About ACE)

Frames

ACE displays two (2) vertically tiled frames.  The 
left frame—the working frame—contains the document 
outline from which the user can build the aviation checklist 
file, while the right frame—the preview frame—shows a 
document preview and can only be modified through the 
left frame.

Toolbar

The ACE toolbar helps to expedite action commands 
and is composed of fifteen command icons, as shown in 
Figure 2-2.  The ACE toolbar can either be hidden or 
shown below the menu bar by clicking the ‘View’ menu, 
then by selecting ‘Toolbar’.  When the toolbar is shown, 
a check mark is displayed in the ‘View’ menu to the left 
of the ‘Toolbar’ menu option.  Conversely, no check mark 
is displayed to the left of this menu option if the toolbar 
is hidden.

Figure 2-2  ACE Toolbar

New Open Save Cut Copy Paste Delete RedoUndo

Add New 

Group Entry
Checklist

Group Entry
Checklist

Properties 

	 NOTE: When the mouse cursor is placed over a 
command icon, a tag describing the command 
icon in question appears below the mouse 
cursor.

	 NOTE: The toolbar cannot be customized.

Status Bar

The status bar can either hidden or shown at the 
bottom of the interface by clicking the ‘View’ menu, then 
by selecting ‘Status Bar’.  When the status bar is shown, a 
check mark is displayed in the ‘View’ menu to the left of 
the ‘Status Bar’ menu option.  Conversely, no check mark 
is displayed to the left of this menu option if the status bar 
is hidden.

	 NOTE: The status bar displays information on 
the mouse cursor location.  For instance, if the 
mouse cursor is placed over the ‘Cut’ icon, the 
words ‘Cut the Item’ appear in the status bar.  

	 NOTE: When the mouse cursor is not over an 
active part of the interface (i.e., if it is neither 
over the menu bar commands, nor over the 
toolbar icons), the status bar displays the word 
‘Ready’.
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2.2	 Working with ACE Files

	 NOTE: G1000 ACE files provided by the aircraft 
manufacturer should not be edited by the 
customer.

Creating a New ACE File

To create a new ACE file, click the ‘File’ menu, then 
click ‘New’, or click the ‘New’ icon located on the toolbar.  
ACE displays a new file composed of a working frame 
containing the highlighted character string  ‘<End of 
Groups>’ (preceded by a grayed-out group icon) and a 
blank, gray preview frame, as shown in Figure 2-3.

	 NOTE: When the ACE application is opened, a 
new ACE file entitled “chklist” is automatically 
presented to the user.

Figure 2-3  New ACE Document

	 NOTE: Only one file can remain open at a 
time.  Thus, if an ACE file is already open and 
the user opens or creates another ACE file, ACE 
first closes the opened file before opening or 
creating the newly requested one (a prompt to 
save the displayed file is presented beforehand, 
as appropriate).

Opening an Existing ACE File

To open an ACE file, click the ‘File’ menu, then click 
‘Open...’, or click the ‘Open’ icon located on the toolbar.

	 NOTE: Links to the last four (4) distinct opened 
ACE files are displayed in the ‘File’ menu, above 
the ‘Exit’ menu option.

Saving an ACE File

To save an ACE file, click the ‘File’ menu, then select 
the ‘Save’ menu option, or click the ‘Save’ icon located on 
the toolbar.

An ACE file can also be saved with a new file name by 
clicking the ‘File’ menu and selecting the ‘Save As...’ menu 
option.

	 NOTE: Neither a new blank ACE file, nor an 
already saved ACE file can be saved with the 
‘Save’ menu option; the ‘Save As...’ menu option 
is the only save menu option available in this 
case.

	 NOTE: All ACE files names end in the extension 
“.ACE”.

	 NOTE: Before uploading the ACE checklist file 
to a Secure Digital (SD) card for the purpose of 
transferring the checklist to an ACE compatible 
product, consult the appropriate OEM or Garmin 
documentation for applicable file name.

Closing an ACE File

ACE files can only be closed by closing the ACE 
application or by opening another ACE document.  To 
close ACE, click the ‘File’ menu, then click ‘Exit’, or click 
the ‘x’ icon located at the top right corner of the application 
interface.
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Checking or Editing File Properties

The following information may be entered in the Ace 
Properties window:

• Checklist Name
• Aircraft Make and Model
• Aircraft Information  

(i.e., aircraft-specific identification)
• Manufacturer Identification
• Copyright Information
• Default Group
• Default Checklist

All of the user-selected information that appears on the 
Ace Properties window is displayed on the ACE compatible 
product display once the corresponding ACE file has 
been loaded onto the system.  For example, the group 
and checklist selected as default items are automatically 
displayed when the ACE checklist is first accessed on the 
ACE compatible product.

Opening the Ace Properties window (Figure 
2-4):

1. Click the ‘Edit’ menu.

2. Select the ‘File Properties...’ menu option.

Figure 2-4  Ace Properties Window

Transferring ACE Files to the ACE compatible 
product

ACE files can be transferred to the system via the SD 
card (Integrated Flight Deck Systems must use the SD card 
that contains terrain information).

To transfer ACE files to an SD card:

1a. If the ACE file is open, use the ‘Save’ or ‘Save 
As...’ File menu option to save the ACE checklist 
to the root directory of the SD card.

1b. If the ACE file is not open, copy this checklist 
file via the file browser application to the root 
directory of the SD card.

	 NOTE: In order to be recognized by the ACE 
compatible product System, the ACE file must 
be named according to the applicable OEM or 
Garmin documentation.

Uploading ACE files onto the Integrated  
Flight Deck System:

1. Ensure that the system is powered off before 
inserting the SD card.

2. Insert the SD card to which the desired ACE 
checklist file has been copied into the SD card 
slot (bottom slot for Integrated Flight Deck 
systems (Figure 2-5).

Figure 2-5  SD Card Insertion

I n s e r t  SD  card 
(bottom card slot 
f o r  I n t e g r a t e d 
Flight Deck units)
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2.3	 Building ACE Documents

Groups, Checklists and Entries

To build an aviation checklist file, the user should 
create a number of groups, checklists, and entries.

Groups

A group is a set of checklists such as that containing 
preflight procedures or in-flight operations.

	 NOTE: The group containing the emergency 
procedures should ALWAYS be the first group 
that appears in the ACE file working frame 
hierarchy so that this group can be the group 
that is automatically displayed on the MFD when 
the EMERGCY softkey of the Checklist Page is 
pressed.

Checklists

A checklist is a subset of a group and is typically 
composed of more than one entry.  An instance of a 
checklist title under the “In-Flight” group could be 
“Climb”, as shown in Figure 2-6.

Figure 2-6  Groups, Checklists and Entries

Group
Checklist

Entry

Working Frame

Entries

An entry is a subset of a checklist and can be formatted 
in various ways depending on the type of information that 
it is meant to present.

The following entry types are available:

• Plain Text – used for paragraphs that do not 
constitute notes, subtitles, warnings, cautions, or 
challenges.

• Note
• Subtitle – title of a section within a checklist.
• Warning
• Caution
• Challenge – if appearing without a response, a 

challenge represents an action to be taken, as in “2. 
Maintain directional control with the brakes and 
rudder.”  A challenge can also be the title of an action 
if it appears with a response.  For instance, “4. Boost 
Pump” could be a challenge and “OFF” could be its 
response.
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Creating Groups

ACE offers the following ways to create groups:

• By clicking the ‘Edit’ menu, then by selecting the 
‘Add New Group...’ option.

• By right-clicking a group, then by selecting the ‘Add 
New Group...’ option.

• By clicking the ‘Add New Group’ icon located on 
the toolbar.

‘Add New Group’ Icon

	 NOTE: In order to create a new group, a group 
must be highlighted in the left frame.  When any 
group is highlighted, options associated with 
groups are selectable by the user, while options 
associated with checklists and entries are grayed 
out and thus not available to the user.

	 NOTE: Upon the creation of a group, a new 
checklist containing a new entry is automatically 
created under the new group.

	 NOTE: To create a group at the end of the 
sequence of groups, highlight the ‘<End Of 
Groups>’ character string by clicking it.  To 
create a group before a specific group, highlight 
the latter by clicking it and use one of the 
aforementioned group creation procedures.

Creating Checklists

ACE offers the following ways to create checklists:

• By clicking the ‘Edit’ menu, then by selecting the 
‘Add New Checklist...’ option.

• By right-clicking a checklist, then by selecting the 
‘Add New Checklist...’ option.

• By clicking the ‘Add New Checklist’ icon located on 
the toolbar.

‘Add New Checklist’ Icon

	 NOTE: To create a checklist at the end of the 
sequence of checklists, highlight the ‘<End 
Of Checklists>’ character string by clicking 
it.  To create a checklist before a specific 
checklist, highlight the latter and use one of the 
aforementioned checklist creation procedures.

Creating Entries

ACE offers the following ways to create entries:

• By clicking the ‘Edit’ menu, then by selecting the 
‘Add New Entry...’ option.

• By right-clicking an entry, then by selecting the ‘Add 
New Entry...’ option.

• By clicking the ‘Add New Entry’ icon located on the 
toolbar.

‘Add New Entry’ Icon

	 NOTE: To create an entry at the end of the 
sequence of entries, highlight the ‘<End Of 
Entries>’ character string by clicking it.  To create 
an entry before a specific entry, highlight the 
latter and use one of the afore-mentioned entry 
creation procedures.
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Cutting, Copying and Deleting Groups, 
Checklists, or Entries

When selected/highlighted, a group, checklist, or entry 
can be cut, copied, or deleted in the following ways:

• By clicking the ‘Edit’ menu, then by selecting the 
‘Cut’, ‘Copy’, or ‘Delete’ option.

• By right-clicking, then by selecting the ‘Cut’, ‘Copy’, 
or ‘Delete’ option.

• By clicking the ‘Cut’, ‘Copy’, or ‘Delete’ icon located 
on the toolbar.

• By using the appropriate keyboard key or keystroke 
combination (i.e., “Ctrl-X”, “Ctrl-C”, and “Del” 
respectively).

Pasting Groups, Checklists, or Entries

When a group, checklist, or entry has been copied 
(and is still in the memory buffer), it can be pasted in the 
following ways:

• By clicking the ‘Edit’ menu, then by selecting the 
‘Paste’ option.

• By right-clicking, then by selecting the ‘Paste’ 
option.

• By clicking the ‘Paste’ icon located on the toolbar.
• By using the “Ctrl-V” keystroke combination.

Figure 2-7  Group Properties Window Figure 2-8  Checklist Properties Window

Editing Group, Checklist, and Entry Properties

ACE offers the following ways to edit properties related 
to groups, checklists, or entries:

• By clicking the ‘Edit’ menu, then by selecting the 
‘Group Properties...’, ‘Checklist Properties...’, or 
‘Entry Properties...’ option.

• By right-clicking the group, checklist, or entry of 
interest, then selecting the ‘Properties’ option.

• By double-clicking the group, checklist, or entry of 
interest.

• By clicking the properties icon of the highlighted 
item (i.e., group, checklist, or entry).

‘Group Properties’ Icon

‘Entry Properties’ Icon

‘Checklist Properties’ Icon

Editing properties

1. Use one of the methods listed above to open 
the Properties window of a group, checklist, or 
entry.

2. Edit properties as appropriate.

3. Click ‘OK’ to apply the properties and close the 
Properties window.
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Editing Entry Properties

Whereas group and checklist properties are limited 
to the group and checklist names respectively, entry 
properties (Figure 2-9) include the following items:

• Text
• Response
• Entry Type
• Justification
• Number of blank lines to follow entry

	 NOTE: By default, a new entry is always formatted 
as a left-justified Challenge with no blank lines 
to follow the entry and with the words “New 
Entry” in the Entry Properties Text box.

Figure 2-9  Entry Properties Window

Text

All keyboard characters and digits may be entered 
in the Text box.  However, ACE does not recognize the 
following symbols:

 `  =  [  ]  ~  @  ^  {  }  |

	 NOTE: If the Text box is left empty upon 
clicking ‘OK’ in the Entry Properties window, 
ACE automatically enters the word “Entry” 
in the Text box.  On the preview window, the 
ACE-inserted word “Entry” is preceded by 
“NOTE: “,“WARNING: “, or “CAUTION: “, if 
appropriate.

Response

The Response box should contain text associated with 
the response to a challenge.  For example, if “1. Mixture” 
is entered in the Text box of a Challenge entry, “CUTOFF” 
could be entered in the Response box.

	 NOTE: The Response box is only usable if the 
entry type has been set to ‘Challenge’.  When 
other types of entries are selected, the Response 
box is grayed out.

	 NOTE: A challenge does not necessarily need to 
be accompanied by a response.
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Entry Type

The following text formatting options are available 
from the Entry Type pulldown list (Figure 2-10):

• Plain Text – white text
• Note – gray text preceded by the word “NOTE: ”
• Subtitle – white text in boldface format
• Warning – yellow text preceded by the word 

“WARNING: ”
• Caution – white text preceded by the word 

“CAUTION: ”
• Challenge – cyan text preceded by a hollow white 

box (text entered in the ‘Response’ box always 
appears right-justified on the checklist).

	 NOTE: Capitalization is user-defined, except 
for the words “NOTE”, “WARNING” and 
“CAUTION”, which automatically precede 
the text entered for the ‘Note’, ‘Warning’ and 
‘Caution’ entry types.

Figure 2-10  Entry Type Pulldown List Figure 2-11  Justification Pulldown List

Justification

The following text justification options for the entry 
types are available from the Justification pulldown list 
(Figure 2-11):

• Left Justified
• Indent 1 Level – corresponds to one (1) left tab
• Indent 2 Levels – corresponds to two (2) left tabs
• Indent 3 Levels – corresponds to three (3) left tabs
• Indent 4 Levels – corresponds to four (4) left tabs
• Center (not available for the ‘Challenge’ entry 

type)

Number of Blank Lines to Follow Entry

A number from zero (0) to ninety-nine (99) can be 
entered in the ‘Number of blank lines to follow entry’ box 
in order to add blank lines between checklist entries.
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2.4	 Using the Help Menu

The Help menu contains the following menu options:

• ACE Help (Figure 2-12) – activates the Help 
capability.

• About ACE (Figure 2-13) – displays the ACE 
software version number.

Figure 2-13  About ACE

Figure 2-12  ACE Help
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